Jump to content
Eclipse

Forester XT MY2015

Recommended Posts

Witam 

 

Od miesiąca oswajam nowego forestera i spotkałem się z pewnymi problemami które mnie nieco irytują. Może ktoś coś podpowie lub zna odpowiedzi na te pytania:

 

1. WSKAŹNIK POZIOMU PALIWA - czasem po tankowaniu do pełna wskaźnik paliwa ustawiał się na 3/4 baku - zdarzyło się tak 2 razy przy 6 tankowaniach w sumie.

Raz zdarzyło mi się zatankować zaraz po zapaleniu się rezerwy ok 18 litrów, a wskaźnik kompletnie nie zareagował - to znaczy nadal paliła się rezerwa i w trakcie jazdy zniknęła ostatnia kreska na wskaźniku napełnienia baku, przejechałem ok 200km z teoretycznie pustym bakiem i po kolejnym tankowaniu wskaźnik znów pokazuje normalnie.

Czy Ten Typ Tak Ma?

 

2. Sygnalizacja dźwiękowa komputera - pewne stany komputer sygnalizuje na wyświetlaczu oraz jednoczesnym sygnałem dźwiękowym ( ostrzeżenie o możliwym oblodzeniu czy o rezerwie paliwa ) i to jest oczywiste. Niestety przynajmniej  kilkanaście razy słyszałem sygnał dźwiękowy ostrzeżenia ale bez żadnych informacji na wyświetlaczu lub zapalonej kontrolki - czasem sygnał powtarza się co parę minut a czasem jest to pojedyńczy dźwięk. Byłem nawet na serwisie sprawdzić ewentualne błędy ale nic nie ma w pamięci kompa. TTTM ?? 

 

3. Klimatyzacja - działanie 0/1 - znalazłem na forum opis problemu i ewentualne możliwości  poprawy tego stanu rzeczy przez montaż wentylatorka na czujniku temperatury przy kolumnie kierownicy. Wie ktoś może czy dla pasażera jest osobny czujnik temperatury a jeśli tak to gdzie on się znajduje.

 

4.Wycieraczki - W trybie auto jest teoretycznie możliwość wyboru szybkości pracy wycieraczek - problem z tym że nawet najmniejsza prędkość jest dla mnie zbyt szybka. Można jakoś ustawić ( spowolnić ) pracę wycieraczek w tym trybie ?

 

pozdrawiam Krzysztof

Share this post


Link to post
Share on other sites
Wycieraczki - W trybie auto jest teoretycznie możliwość wyboru szybkości pracy wycieraczek - problem z tym że nawet najmniejsza prędkość jest dla mnie zbyt szybka. Można jakoś ustawić ( spowolnić ) pracę wycieraczek w tym trybie ?

W trybie auto jest możliwa regulacja czułości sensora deszczu w konsekwensji regulacja interwału czasowego pomiędzy cyklami pracy.

 

 

WSKAŹNIK POZIOMU PALIWA

U mnie tak nie było ani nie jest, nikt też się na to nie skarżył na Forum o ile dobrze pamiętam (ale raczej dobrze pamiętam :) ). Zapytaj w ASO, albo poczekaj może przejdzie z czasem;

 

 

Sygnalizacja dźwiękowa

Sprawdż czy to nie ostrzezenia o radarach z navi nie sa aktywne (z tego co pamietam na Forum ktoś tak miał).

Edited by mechanik

Share this post


Link to post
Share on other sites

Ad. 2 Wejdź w ustawienia nawigacji i powyłączaj powiadomienia dźwiękowe. Teraz nie pamiętam dokładnie która opcja jest odpowiedzialna za generowanie powiadomienia w sytuacjach jak dla mnie losowych. Nie potrafiłem tego powiązać z niczym. U mnie działo się tak nawet przy wyłączone nawigacji.

Share this post


Link to post
Share on other sites

Ad 1

jedz do ASO, nie jest to normalny objaw byc moze cos jest nie ok z czujnikiem poziomu paliwa

Share this post


Link to post
Share on other sites

Witam 

 

Od miesiąca oswajam nowego forestera i spotkałem się z pewnymi problemami które mnie nieco irytują. Może ktoś coś podpowie lub zna odpowiedzi na te pytania:

 

1. WSKAŹNIK POZIOMU PALIWA - czasem po tankowaniu do pełna wskaźnik paliwa ustawiał się na 3/4 baku - zdarzyło się tak 2 razy przy 6 tankowaniach w sumie.

Raz zdarzyło mi się zatankować zaraz po zapaleniu się rezerwy ok 18 litrów, a wskaźnik kompletnie nie zareagował - to znaczy nadal paliła się rezerwa i w trakcie jazdy zniknęła ostatnia kreska na wskaźniku napełnienia baku, przejechałem ok 200km z teoretycznie pustym bakiem i po kolejnym tankowaniu wskaźnik znów pokazuje normalnie.

Czy Ten Typ Tak Ma?

 

 

Raz mi się coś takiego przytrafiło, ale po ponownym uruchomieniu silnika pokazywał właściwy poziom paliwa...czyli do pełna

Edited by mattew

Share this post


Link to post
Share on other sites

Ad. 2 Wejdź w ustawienia nawigacji i powyłączaj powiadomienia dźwiękowe. Teraz nie pamiętam dokładnie która opcja jest odpowiedzialna za generowanie powiadomienia w sytuacjach jak dla mnie losowych. Nie potrafiłem tego powiązać z niczym. U mnie działo się tak nawet przy wyłączone nawigacji.

Z tego co ja zaobserwowałem to są to powiadomienia z TMC. Pojawia się rzadko bo u nas TMC nie działa, ale ja czasami odbieram jakieś z Czech i wtedy pika. Raz koło Wrocławia pojawiały się jakieś komunikaty dotyczące korków na A4 i wtedy pikało sobie radośnie...

 

Krawiec

Share this post


Link to post
Share on other sites

Najlepiej sprawdzic tak zwane  BIU  (Body Integrated Unit)  w ASO

Po podpieciu auta przez OBD do Komputera z Programem "Subaru Selekt Monitor III".

 

Wszystkie te systemy ktore u ciebie funkcjonuja blednie sa sterowane przez BIU.

Podpiecie tylko do testera bez wybrania w programie sekcji BIU nic nie da.

Potrzebny pelny test funkcji  BIU.

Bledy BIU nie sa nigzie do zobaczenia poza sekcja programu dotyczaca BIU.

 

Moje doswiadczenia z servisem subaru wskazuja na czeste niedouczenie personelu w obsludze programu

Subaru Selekt Monitor.

 

Generalnie w Zaglebiu Rury stwierdzilem Informatyczny analfabetyzm u pracownikow Subaru Deutschland.

 

do 1) Defekt czujnika lub BIU

 

do 2) Masz napewno na mysli Display srodkowy (przed szyba przednia). Jezeli Tak-  Display lub BIU defekt

 

do 3)  Czujnik defekt lub Polaczenie / kostka

 

Wentylatorek to idiotyzm (sorry). 

Czujnik znajduje sie w prawo od kolumny kierownicy na desce rozdzielczej .

Na wysokosci gdzie znajduje sie stacyjka lub jej zaslepka.

Wyglada to jak mala kratka / kilka pionowych szczelin

 

do 4) Mozna to ustawic. Instrukcja obslugi. Jezeli nie - BIU ...

Edited by Forest Gump

Share this post


Link to post
Share on other sites

Ogrzewanie w XT My15 tak działa. 19.5 st. zamraża a przy 20.0st. robi saunę.

Trzeba się przyzwyczaić.

Share this post


Link to post
Share on other sites

 

 

19.5 st. zamraża a przy 20.0st. robi saunę

No właśnie, też to zaobserwowałem... ;)

Share this post


Link to post
Share on other sites

@Dotorre

@Adam 12

Te typy napewno tak nie maja,

a jezeli maja to sa zepsute.

W zaleznosci od zastosownego panelu sterowania i wyswietlacza przed szyba przednia mozna, przeprowadzic samotest (self test) klimatyzacji.

Ale (ide o zaklad) ze 8 na 10 pracownikow ASO-subaru  nawet tego nie wie :-)

Czesto sa te testy przeprowadzane blednie ( jezeli )

Zapominaja o sensorze naslonecznienia. (sun load sensor)

Innym zrodlem bledöw jest sensor temperatury zewnetrznej.

Za zdezakiem a przed chlodnica.

Objawem usczkodzenia tego sensora jest powolna reakcja wskaznika temperatury zewnetrznej na MFD (Multi Funktion Display) przed szyba przednia.

Definitywnie pelnosprawna klimatyzacja forestera pracuje plynnie i przyjemnie a nie 0/1

Wsjo rawno: turbo czy nie.

To co ja zauwzylem  subaru tutaj ma stosunkowo szkolo-odpornych mechanikow.

Na 4 warsztaty w Zaglebiu Ruhry zaden kolek nie wiedzial prawie nic o elektronice w nowym Forku.

 

Niewiem jak w polsce, ale spodziewam sie ze szkolenie personelu sprowadza sie do tego ze wlascicel warsztatu pobalowal na kursie.

Tak funkcjonowalo to w mojej firmie.

 

Ma moze ktos  Instrukcje warsztatowa Forka MY14  (SJ) jako PDF ?

Wszystkie modele w wersji Europejskiej.

W zamian oferuje wszystkie dla fork SJ i SH (wszystkie wersje USA).

Poszukuje schematu i opisu funkcji Start/ Stop.

Czy przycisk aktywacji pracuje na mase (-)  czy steruje plusem.

Napiecie sterowania i czas impulsu.

Chce dobudowac uklad pamieci tak, zeby ten szajs wiedzial, ze ma byc zawsze po starcie silnika OFF albo ON

bez koniecznosci kazdorazowej dezaktywacji po starcie.


Jeszcze jedno.

Czujnik temperatury zewnetrznej (Ten za zdezakiiem)

i Sun Load na podszybiu steruja profilem pracy ukadu kontrolnego klimy.

Jezeli sa uszkodzone (a jest to choroba tego auta) moze dochodzic do "twardej" pracy Klimatyzacji (sauna albo krag polarny).

Edited by Forest Gump

Share this post


Link to post
Share on other sites

Muszę przyznać że nie mam zastrzeżeń do pracy układu wentylacji, ogrzewania i klimy w moim Fotesterze. Wydaje mi się że ten typ tak nie ma. No chyba że klimatyzacja,system ogrzewania i wentylacji różni się w Forku z silnikiem wolnossącym i DIT ale szczerze w to wątpię.

Share this post


Link to post
Share on other sites

Zadne z tych błędów u mnie nie występuje. Kolejny raz czytam o problemach z klimatyzacją / nagrzewnicą, których po prostu nie mam, więc nie, to nie TTTM.

 

Forest dzięki za wyjaśnienie. :)

 

Wysłane z mojego SGP521 przy użyciu Tapatalka

Share this post


Link to post
Share on other sites

 

 

Ogrzewanie w XT My15 tak działa. 19.5 st. zamraża a przy 20.0st. robi saunę. Trzeba się przyzwyczaić.

w xv podobnie moze nie zamraza bo np przy ustawieniu 19.5st. C leci zimne powietrze a ustawiajac juz 0,5 st C wiecej leci gorace...

Share this post


Link to post
Share on other sites

Byłem dziś w ASO i jestem nieco ...zdegustowany. ASO nie rozwiązało żadnego problemu, a nawet dodatkowa rzecz jaką chciałem zrobic ( aktualizacja softu stacji multimedialnej ) chyba nie została załatwiona do tak jak należy.

 

Co do wskaźnika paliwa nie mają pomysłu co z tym zrobić. Sugerują że przyczyną mogło być tankowanie przy uruchomionym silniku i to wprowadza zakłócenia we wskazaniach. Co do kontrolki rezerwy to wyczytałem w instrukcji iż trzeba zatankować min 17l by zgasła, ja wlałem prawie 19 ale być może to było ciut za mało. Nie tłumaczy to jednak błędnych wskazań samego wskaźnika - potestuję jeszcze ze 2-3 tankowania czy problem się ponowi.

 

Klimatyzacja - zaczekam również na cieplejsze dni jak będzie się wtedy zachowywała.

 

Jedynie sygnały ostrzegawcze chyba faktycznie są to dźwięki z nawigacji, choć nadal nie wiadomo przed czym ostrzegają.

 

 

Chcialem zaktalizować soft stacji by mieć mirrorlink 1.1 i uruchomić w końcu połączenie z fonem oraz mieć możliwość wyciszenia nawigacji ( miał przybyć przycisk do wyciszenia w nawigacji ) ale o to średnio wyszło - nawigacja niby zaktualizowana ale telefon nadal się nie łączy z mirror link a w nawi nie ma tego przycisku.... 

Share this post


Link to post
Share on other sites

Tankowanie z wloczonym zaplonem faktycznie wprowadza blad, poniewaz komputer dostaje sygnal, ze poziom paliwa rosnie (w grubym skrocie).

Wylaczenie zaplonu i ponowne wloczenie po kilku sekundach likwiduje ten efekt.

Reset komputera likwiduje to natychmiast.

Po resecie po minimum 10 sekundach wlaczyc zaplon na 1-2 minuty Bez startu silnika lub dotykania pedalu gazu.

Wazne poniewaz w tym czasie ECU ustala punkt zerowy przepustnicy.

Teraz zastartowac silnik i nagrzac go na wolnych obrotach do temperatury pracy.

Po tym czasie mozna jechac. Silnik i CVT ucza sie teraz twojego stylu jazdy od nowa.


Reset komputera mozesz przeprowadzic sam.

Odpiac minus od Akku. Czas u mnie to 30 minut.

Najpewniej na noc w garazu.

Bledy i stany licznikow nie beda skasowane ale nastepuje reset wszystkich wejsc- zapamietanych wartosci sygnalow od czujnikow.

Przed odlaczeniem Akku wylacz wszystkie odbiorniki pradu, radio, oswietlenie klima etc.


Moje doswiadczenia z serwisem Subaru sa takie same.

Tyle ze moj service nauczyl sie patzec co robie u nich z ich nazedziami.

Smutne.

 

Moj Forester dostal ultimatum:

Jedna Awaria na drodze przed uplywem 160 000 Km. i jest sprzedany.

 

Narazie sie bardzo pilnuje.

 

Duperele elektroniczne sa poza ultimatum, tak dlugo jak moge dojechac bez straty komfortu do domu.

Fajne auto ale jakosc serwisu to czesto katastrofa.

 

W zaglebiu Ruhry trudno o dobry service Subaru.

W rejonach gorskich gdzie Subaru jest o wiele popularniejscz wyglada to o niebo lepiej.

Edited by Forest Gump

Share this post


Link to post
Share on other sites

 

 

4.Wycieraczki - W trybie auto jest teoretycznie możliwość wyboru szybkości pracy wycieraczek - problem z tym że nawet najmniejsza prędkość jest dla mnie zbyt szybka. Można jakoś ustawić ( spowolnić ) pracę wycieraczek w tym trybie ?

to się kalibruje: chyba guzik spryskiwacza oraz przestawienie na automat jednocześnie - tak miałem w innych autach

Share this post


Link to post
Share on other sites

 

4.Wycieraczki - W trybie auto jest teoretycznie możliwość wyboru szybkości pracy wycieraczek - problem z tym że nawet najmniejsza prędkość jest dla mnie zbyt szybka. Można jakoś ustawić ( spowolnić ) pracę wycieraczek w tym trybie ?

to się kalibruje: chyba guzik spryskiwacza oraz przestawienie na automat jednocześnie - tak miałem w innych autach
@AdaSch, mógłbyś trochę przybliżyć, jeśli możesz? Guzik? Spryskiwacz uruchamia się przez pociągnięcie dźwigienki sterowania wycieraczkami. I co dalej należy zrobić celem kalibracji?

Share this post


Link to post
Share on other sites

Byłem dziś w ASO i jestem nieco ...zdegustowany. ASO nie rozwiązało żadnego problemu, a nawet dodatkowa rzecz jaką chciałem zrobic ( aktualizacja softu stacji multimedialnej ) chyba nie została załatwiona do tak jak należy.

 

Co do wskaźnika paliwa nie mają pomysłu co z tym zrobić. Sugerują że przyczyną mogło być tankowanie przy uruchomionym silniku i to wprowadza zakłócenia we wskazaniach. Co do kontrolki rezerwy to wyczytałem w instrukcji iż trzeba zatankować min 17l by zgasła, ja wlałem prawie 19 ale być może to było ciut za mało. Nie tłumaczy to jednak błędnych wskazań samego wskaźnika - potestuję jeszcze ze 2-3 tankowania czy problem się ponowi.

 

Klimatyzacja - zaczekam również na cieplejsze dni jak będzie się wtedy zachowywała.

 

Jedynie sygnały ostrzegawcze chyba faktycznie są to dźwięki z nawigacji, choć nadal nie wiadomo przed czym ostrzegają.

 

 

Chcialem zaktalizować soft stacji by mieć mirrorlink 1.1 i uruchomić w końcu połączenie z fonem oraz mieć możliwość wyciszenia nawigacji ( miał przybyć przycisk do wyciszenia w nawigacji ) ale o to średnio wyszło - nawigacja niby zaktualizowana ale telefon nadal się nie łączy z mirror link a w nawi nie ma tego przycisku.... 

Nie wiem w jakim ASO byłeś ale ja serwisuję w ASO w Poznaniu i dla samego serwisu kupiłbym subaru jeszcze raz....

Share this post


Link to post
Share on other sites

Zadne z tych błędów u mnie nie występuje. Kolejny raz czytam o problemach z klimatyzacją / nagrzewnicą, których po prostu nie mam, więc nie, to nie TTTM.

 

Forest dzięki za wyjaśnienie. :)

 

Wysłane z mojego SGP521 przy użyciu Tapatalka

 

 

jeździłem trzema różnymi XT MY15 i w każdym było podobnie. Nie jest to bardzo uciążliwe ale jest faktem. Efekt zauważalny tylko w lecie na klimie bez trybu auto.

Share this post


Link to post
Share on other sites

 

Zadne z tych błędów u mnie nie występuje. Kolejny raz czytam o problemach z klimatyzacją / nagrzewnicą, których po prostu nie mam, więc nie, to nie TTTM.

 

Forest dzięki za wyjaśnienie. :)

 

Wysłane z mojego SGP521 przy użyciu Tapatalka

 

jeździłem trzema różnymi XT MY15 i w każdym było podobnie. Nie jest to bardzo uciążliwe ale jest faktem. Efekt zauważalny tylko w lecie na klimie bez trybu auto.

A ja jeździłem pięcioma różnymi...bawimy się w licytacje? ;)

 

Teraz jestem po kolejnej trasie 1400 km na raz, całe auto ludzi i nikt nie narzekał na ciepło/zimno w Forku. Może my rodzinne gruboskorni jesteśmy.

Share this post


Link to post
Share on other sites

 

Byłem dziś w ASO i jestem nieco ...zdegustowany. ASO nie rozwiązało żadnego problemu, a nawet dodatkowa rzecz jaką chciałem zrobic ( aktualizacja softu stacji multimedialnej ) chyba nie została załatwiona do tak jak należy.

 

Co do wskaźnika paliwa nie mają pomysłu co z tym zrobić. Sugerują że przyczyną mogło być tankowanie przy uruchomionym silniku i to wprowadza zakłócenia we wskazaniach. Co do kontrolki rezerwy to wyczytałem w instrukcji iż trzeba zatankować min 17l by zgasła, ja wlałem prawie 19 ale być może to było ciut za mało. Nie tłumaczy to jednak błędnych wskazań samego wskaźnika - potestuję jeszcze ze 2-3 tankowania czy problem się ponowi.

 

Klimatyzacja - zaczekam również na cieplejsze dni jak będzie się wtedy zachowywała.

 

Jedynie sygnały ostrzegawcze chyba faktycznie są to dźwięki z nawigacji, choć nadal nie wiadomo przed czym ostrzegają.

 

 

Chcialem zaktalizować soft stacji by mieć mirrorlink 1.1 i uruchomić w końcu połączenie z fonem oraz mieć możliwość wyciszenia nawigacji ( miał przybyć przycisk do wyciszenia w nawigacji ) ale o to średnio wyszło - nawigacja niby zaktualizowana ale telefon nadal się nie łączy z mirror link a w nawi nie ma tego przycisku.... 

Nie wiem w jakim ASO byłeś ale ja serwisuję w ASO w Poznaniu i dla samego serwisu kupiłbym subaru jeszcze raz....

 

Fajnie ze są takie serwisy, niestety do Poznania mam za daleko. 

 

Dziś byłem w tej samej sprawie w innym ASO - tutaj jeszcze większa porażka, wgrali mi "najnowszy soft" oczywiście z wiadomym skutkiem - porażka.

W południe dostałem info z działu technicznego Subaru że aktualny soft z mirror linkiem 1.1 ma numer ME 9910,  ja zostałem uraczony w pierwszym ASO softem ME9909 ( czyli całkiem blisko) a dzisiaj w drugim ASO softem ME9107 czy jakimś archiwalnym. Może za trzecim razem się uda  :D

Edited by Eclipse

Share this post


Link to post
Share on other sites

 

 

Poszukuje schematu i opisu funkcji Start/ Stop. Czy przycisk aktywacji pracuje na mase (-) czy steruje plusem.

Masą!

Share this post


Link to post
Share on other sites

 

 

Byłem dziś w ASO i jestem nieco ...zdegustowany. ASO nie rozwiązało żadnego problemu, a nawet dodatkowa rzecz jaką chciałem zrobic ( aktualizacja softu stacji multimedialnej ) chyba nie została załatwiona do tak jak należy.

 

Co do wskaźnika paliwa nie mają pomysłu co z tym zrobić. Sugerują że przyczyną mogło być tankowanie przy uruchomionym silniku i to wprowadza zakłócenia we wskazaniach. Co do kontrolki rezerwy to wyczytałem w instrukcji iż trzeba zatankować min 17l by zgasła, ja wlałem prawie 19 ale być może to było ciut za mało. Nie tłumaczy to jednak błędnych wskazań samego wskaźnika - potestuję jeszcze ze 2-3 tankowania czy problem się ponowi.

 

Klimatyzacja - zaczekam również na cieplejsze dni jak będzie się wtedy zachowywała.

 

Jedynie sygnały ostrzegawcze chyba faktycznie są to dźwięki z nawigacji, choć nadal nie wiadomo przed czym ostrzegają.

 

 

Chcialem zaktalizować soft stacji by mieć mirrorlink 1.1 i uruchomić w końcu połączenie z fonem oraz mieć możliwość wyciszenia nawigacji ( miał przybyć przycisk do wyciszenia w nawigacji ) ale o to średnio wyszło - nawigacja niby zaktualizowana ale telefon nadal się nie łączy z mirror link a w nawi nie ma tego przycisku.... 

Nie wiem w jakim ASO byłeś ale ja serwisuję w ASO w Poznaniu i dla samego serwisu kupiłbym subaru jeszcze raz....

 

Fajnie ze są takie serwisy, niestety do Poznania mam za daleko. 

 

Dziś byłem w tej samej sprawie w innym ASO - tutaj jeszcze większa porażka, wgrali mi "najnowszy soft" oczywiście z wiadomym skutkiem - porażka.

W południe dostałem info z działu technicznego Subaru że aktualny soft z mirror linkiem 1.1 ma numer ME 9910,  ja zostałem uraczony w pierwszym ASO softem ME9909 ( czyli całkiem blisko) a dzisiaj w drugim ASO softem ME9107 czy jakimś archiwalnym. Może za trzecim razem się uda  :D

 

Oho, a już myślałem, że tylko wersje Platinum (ja mam Comfort) dostają właściwego mirrorlinka, ale widzę, że jest to uzależnione od serwisu. Podejrzewam, że byliśmy w tym samym serwisie (w mieście na "K":-), nawet specjalnie zerwałem się z pracy (na szczęscie mam z pracy do serwisu może ze 2 km), zeby mirrorlinka uaktualnić a tu taka niemiła niespodzianka. Niedługo będzie pora wymiany opon, więc spytam, czy już mają właściwy soft.

Co do samego softu, na początku lutego poszła "oficjalna" informacja z SIP, że wszystkie serwisy dostały soft z mirrorlinkiem 1.1, no ale jak to zwykle bywa w korporacji - komunikacyjny chaos:-)

Share this post


Link to post
Share on other sites

 

 

A ja jeździłem pięcioma różnymi...bawimy się w licytacje? ;)

 

nie wiem dlaczego ale efekt był zauważalny tylko i wyłącznie w upały. Widocznie wszystkie były "popsute" skoro klima działała tak samo.

Share this post


Link to post
Share on other sites

@m_dz

Wielkie dzieki.

Zabieram sie za lutownie :)

Minus uprosci kostrukcje modulu.

Wnerwia mnie to cudo, a czesto zapominam to wylaczyc po starcie.

Edited by Forest Gump

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...