Jump to content

Wymiana ECU, a immobilizer


lordpix
 Share

Recommended Posts

Pacjent: Blob 2003 

ECU prodrive 2005.

 

Problem polega na tym, że auto czasem odpala, a czasem nie.

Zaczęło się od tego, że chciałem wrócić do zwykłego wydechu (z przelotówki).

Przy okazji wymieniłem więc ECU na prodrive. Miałem do tego ECU kluczyk i całą kolumnę kierowniczą z immo.

Mechanik wymienił ECU, a immo razem z kluczykiem podczepił pod kolumną kierowniczą zastępując stary immobilizer.

Odpalam to starym kluczykiem, a ten nowy zestaw (ECU, kluczyk i immo) są cały czas wpięte.

Jak to testował to wszystko działało. Przyjechałem po auto, przekręcam kluczyk i oczywiście nie odpala.

Świeci się na desce czerwony kluczyk.

Za trzecim razem odpalił, za czwartym też..... Dzisiaj rano znowu dopiero za trzecim.

Nie wiem czy to ma wpływ, ale jest tez turbotimer. Ale jak silnik odpali to działa jak powinien.

O co chodzi? Nie chcę żeby mi auto nagle gdzieś odmówiło jazdy na środku skrzyżowania :/

 

Link to comment
Share on other sites

Zdaję sobie z tego sprawę. Na szczęście auta nigdzie nie zostawiam "na ulicy" ale coś trzeba z tym zrobić.

Chyba lepiej jeśli ten drugi kluczyk, który jest zgodny z immo też powinienem nosić ze sobą i w momencie jak chce gdzieś jechać to go wkładam gdzie trzeba.

Nie zmienia to jednak faktu, że auto nie odpala za każdym razem. No i dlaczego się tak dzieje?

Link to comment
Share on other sites

niech Ci kolego ogarnięty elektryk / elektronik przelutuje kostkę imobilajzera z oryginalnego ecu do tego z Prodrive i będzie grała muzyka.

Też mam u siebie Ecu Prodrive i tak to zostało zrobione jak opisałem wyżej. Odpalanie oczywiście z oryginalnego kluczyka.

Link to comment
Share on other sites

KaTm, nie wiem czy dobrze rozumiem, chodzi ci o to żeby ze starego ECU (nr 1 foto) wylutować kostkę i wlutować ją do ECU prodrive zostawiając resztę tą co była?

Trochę mi to ryzykownie brzmi. Można uwalić dwa ECU za jednym razem.

 

cf71e6c54c0cddf8m.jpg

Link to comment
Share on other sites

Zgaduję, że reszta jest w aucie.

Może postaram się napisać dokładniej jak to jest chociaż sam nie rozumiem dokładnie jak to działa.

 

Stacyjka i kluczyk do uruchomienia auta - stare.

ECU, immo, kluczyk - prodrive. Kluczyk z tego co widziałem był wpięty (chyba do stacyjki?) i podczepiony pod kierownicą.

 

I pytanie jest takie - czemu raz działa, a raz?

Czy jeśli się już uruchomi to może zgasnąć w czasie jazdy? Nie to, że chcę to tak zostawić, ale wolę być przygotowany.

Link to comment
Share on other sites

A te ecu takie same pod ten sam silnik AVCS i całe duperele. Bo cos jest nie tak skoro nie odpala nie wywala żadnych błędów check engin.

Aha druga stacyjka wisi sobie i wniej siedzi kluczyk i do niego jest nowe ecu podpięte ok a odpalasz stara stacyjka.

Link to comment
Share on other sites

Silnik jest dokładnie od tego ECU (z jednego auta dokupiłem silnik, ECU, i całą kolumnę z immo, stacyjką i kluczykiem). Chciałem aby jak najwięcej części było zgodnych ze sobą dlatego zacząłem to wymieniać.

Wymiana wydechu przelot >> seria wymusił wymianę ECU, a to znowu immo. I byłoby już ok, bo nie mam błędów sondy z wydechu tylko nie wiem czemu nie odpala za każdym razem.

No i wg mnie powinno to działać. Skoro stary kluczyk tylko służy do przekręcenia i odpalenia.

Nie wiem o co chodzi.

Link to comment
Share on other sites

KaTm, nie wiem czy dobrze rozumiem, chodzi ci o to żeby ze starego ECU (nr 1 foto) wylutować kostkę i wlutować ją do ECU prodrive zostawiając resztę tą co była?

Trochę mi to ryzykownie brzmi. Można uwalić dwa ECU za jednym razem.

 

cf71e6c54c0cddf8m.jpg

Tak, dokładnie o to mi chodzi . Mam tak u siebie zrobione. 

Podobno można tez zgrać mapę z Prodrive i wgrać na oryginalne ecu - trzeba mieć jakiś kabel do bezpośredniego  podłączenia ecu do komputera - tak mówił mi mój elektryk. Z racji tego , że kabla nie było elektryk zrobił mi przelutowanie kości z mojego ecu do prodrive. Teraz mam u siebie ecu prodrive a na półce leży oryginalny ecu bez kości imo :)

 

aha i jeszcze jedno - mój magik elektryk mówił mi (bo też się bałem o to, że może zepsuć dwa ecu naraz) , że nie ma ryzyka to prosta operacja dla niego bo robi takie zabiegi bardzo często :)

Kosztowało mnie to 150,-zł .

Edited by KaTM
Link to comment
Share on other sites

nie rozumiem za bardzo takich kombinacji …. przy wymianie samego ECU nie trzeba nic kombinowac tylko zaprogramowac ponownie kluczyk i tyle , trwa to 20 sek. i gotowe …. 

Link to comment
Share on other sites

dareckiislandia, ja jeszcze nic nie miałem lutowane. Rozważam różne opcje.

 

Mnie też się zdawało, że najprościej zrobić jak pisze carfit. Nawet swego czasu o to pytałem bo wiedziałem, że mnie to czeka.

Ale niby było zrobione i działało. A nie działa.

 

Zawsze mogę wrócić do starego immo i przeprogramować kluczyk. Tylko powiedzcie mi czy do tej operacji jest potrzebne całe auto czy wystarczą 2 kluczyki?

Bo jeśli mam teraz ECU prodrive i wrócę do starego immo to i tak auta nie odpalę i nie dojadę do kogoś kto to przeprogramuje.

Link to comment
Share on other sites

nie rozumiem za bardzo takich kombinacji …. przy wymianie samego ECU nie trzeba nic kombinowac tylko zaprogramowac ponownie kluczyk i tyle , trwa to 20 sek. i gotowe …. 

Zapewne tak jest Carfit ale jak ktoś nie wie jak zaprogramować kluczyk to szuka innego rozwiązania. Do tej operacji programowania kluczyka potrzebny jest jakiś specjalny sprzęt ? 

Link to comment
Share on other sites

A mnie się jeszcze jedna rzecz przypomniała i obym się mylił.

Jak dostałem kolumnę kierowniczą to tam był wyprowadzony jeden przecięty kabel. Właściciel mówił, ze w schowku było jakieś dodatkowe zabezpieczenie na kod.

Teoretycznie było to przerwanie przewodu i ponowne jego łączenie (kodem, przyciskiem itp) powinno sprawić, że to będzie funkcjonowało.

Gorzej jeśli to było coś, co sprawiało, ze to działa :/

 

Jeśli tak jest to chyba zostaje rozwiązanie które proponował KaTM.

 

EDIT:

Przeszedłem się do auta i zrobiłem zdjęcia:

 

To jest kostka z kompletu ECU-kluczyk Prodrive.

27dfe0fdc7caca99m.jpg

 

 

1 - wtyczka od kluczyka w stacyjce, odpięty bo to nie kluczyk od nowego immo
2 - kluczyk prodrive podpięty do 3 - kostka prodrive

433e5ded44f1847cm.jpg

 

c.d tego samego

5aec2655e8f5522bm.jpg c94f8361d1176a75m.jpg

 

Kostka prodrive i wpięty kabel od czujnika z kluczykiem prodrive

38e5d478402c3899m.jpg

 

 

No i żeby było weselej, dzisiaj odpalił 4 x pod rząd i nic się nie działo.

 

Pytanie poza tematem. Co to za kostka obok OBD?

07c727422e218b2dm.jpg

 

* można się śmiać ze strzałek z painta. Nie mam PS na tym kompie:)

Edited by lordpix
Link to comment
Share on other sites

filester, zgadzam się, aczkolwiek nie pomogłeś mi. To, że nie działa to wiem. Temat założyłem po to, żeby problem rozwiązać.

 

dareckiislandia, to jest jakieś nowe podejście do tematu.

Chodzi ci o wyjęcie z kluczyka prodrive chipa i włożenie do tego, którym odpalam?

 

7285f4672003b0b6med.jpg

 

Czy w kluczyku ta płytka (nr 2) to tylko pilot do centralnego? A to czarne - nr 1 to immo?

 

Jeśli tak, to:

 

- przełożyć do starego kluczyka który wchodzi do stacyjki część nr 1 z kluczyka prodrive

- podpiąć stacyjkę kablem do tej kostki prodrive (poniżej)

27dfe0fdc7caca99m.jpg

 

 

Dobrze kombinuję czy to pomysł na bombę?

Edited by lordpix
Link to comment
Share on other sites

Czy jeśli się już uruchomi to może zgasnąć w czasie jazdy?

 

Nie powinie już zgasnąć z powodu braku kontaktu z imo, nawet jest czasem tak jak skontaktuje się już z imo i odblokuje sterownik to po chwili zapali na innym kluczyki ,ale to musi być szybko zrobione

 

 

Przełóż tą czarną psrtkę i ma odpalić

Edited by Grzesiek79
Link to comment
Share on other sites

Hehe. Najpierw jadł obiad a później robił ;)

Robił, robił i zrobił.

 

dareckiislandia, masz u mnie paczkę paluszków i żelki.

 

Podłączyłem jak napisałeś i na razie jest OK. Trochę to małe gówienko nie pasowało bo była inna wsuwka, ale jakoś poprzekładałem i weszło idealnie.

 

Efekt jest taki, że wywalony jest ten dodatkowy kabel, immo łapie normalnie ze stacyjki i nikt nie uruchomi auta gwoździem.

Minus - mam tylko 1 immo w kluczyku. Jak zgubię to klops. Trzeba coś dorobić na wszelki wypadek.

Z ciekawości próbowałem odpalić zapasowym kluczykiem i nie dało rady. Czyli tak jak być powinno.

 

Na razie jestem szczęśliwy, będę testował przez najbliższe dni.

 

Dziękuję za pomoc!

 

Edit: Z palmą? Ja nie z tych;) Wolę przy aucie pogrzebać. Przynajmniej jest efekt.

Edited by lordpix
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...