Jump to content

co zakłóca pracę gps telefonu?


franek-b
 Share

Recommended Posts

Ponieważ jeżdżę na google mapach (ze względu na online'owe podgląd ruchu na drogach), ostatnio zaczął mi wariować czujnik gps. Po przesiadce do innego auta, objawy ustąpiły (normalnie tele pokazywał mapy). Czy możliwe, że coś w aucie zakłóca sygnał gps, czy jednak szukać przyczyny w moim iphonie?  
Słyszeliście o czymś takim? 

Edited by franek-b
Błąd ortograficzny
Link to comment
Share on other sites

Jakie umiejscowienie telefonu w obu autach, jakie uchwyty?

I na czym polega wariowanie czujnika GPS?

 

Najczęściej występują efekty:

-pływania (spowodowane słabym sygnałem GPS lub jego zakłóceniami - jeżeli np. telefon jest w miejscu gdzie ma utrudniony "widok" satelity)

-obracanie i przeskakiwanie (spowodowane zakłóceniem kompasu - jeżeli np. telefon jest w uchwycie magnetycznym)

 

Natomiast co do EyeSight nie wydaje mi się, żeby mogło to w jakikolwiek sposób zakłócać GPS czy jakiekolwiek inne fale.

Edited by LosioDriver
Link to comment
Share on other sites

44 minuty temu, LosioDriver napisał:

Jakie umiejscowienie telefonu w obu autach, jakie uchwyty?

 

-obracanie i przeskakiwanie (spowodowane zakłóceniem kompasu - jeżeli np. telefon jest w uchwycie magnetycznym)

 

Umiejscowienie w zasadzie takie samo, czyli na najprostszym uchwycie mechanicznym, umiejscowionym na kratce nawiewu, centralnie.

 

Obracanie/przeskakiwanie jakby nie mógł wyznaczyć kierunku, pokazywał najczęściej odwrotnie kierunek jazdy niż faktycznie jechaliśmy tj. na mapa wyznaczała trasę, jechaliśmy po trasie (pokazywane przemieszczanie) a strzałka skierowana odwrotnie do kierunku przemieszczania się po mapie - nie wiem czy jasno to opisałem. 

 

To może wina fabrycznej navi? telefon opiera się o górę jednostki (okolice potencjomentru).

Edited by franek-b
Link to comment
Share on other sites

17 minut temu, franek-b napisał:

Obracanie/przeskakiwanie jakby nie mógł wyznaczyć kierunku, pokazywał najczęściej odwrotnie kierunek jazdy niż faktycznie jechaliśmy tj. na mapa wyznaczała trasę, jechaliśmy po trasie (pokazywane przemieszczanie) a strzałka skierowana odwrotnie do kierunku przemieszczania się po mapie - nie wiem czy jasno to opisałem. 

 

Na 99% procent wariowanie kompasu. Nie wiem jak jest w jabłuszku, ale gdzieś powinna być kalibracja kompasu. W Google Maps normalnie kalibrację można wywołać klikając na naszą pozycję w podglądzie mapy (bez nawigacji, po prostu mapa). Zobacz czy w pobliżu telefonu nie ma jakiś magnesów/ferromagnetyków. Zakłócenia mogą też powodować sygnały elektromagnetyczne ale to raczej się zdarza w pociągach :)

 

Edit: To może się przydać: https://www.imore.com/compass-app#calibrate

 

Edited by LosioDriver
Link to comment
Share on other sites

8 godzin temu, franek-b napisał:

Obracanie/przeskakiwanie jakby nie mógł wyznaczyć kierunku, pokazywał najczęściej odwrotnie kierunek jazdy niż faktycznie jechaliśmy tj. na mapa wyznaczała trasę, jechaliśmy po trasie (pokazywane przemieszczanie) a strzałka skierowana odwrotnie do kierunku przemieszczania się po mapie - nie wiem czy jasno to opisałem. 

 

Mam czasami dokładnie tak samo (Iphone SE). Raczej nie jest to jednak związane z EyeSight - bo występowałoby permanentnie - a tak się nie dzieje. Telefon mam w uchwycie na szybie.

Link to comment
Share on other sites

Dzięki za podpowiedzi, jednak wygląda, że to nie jest problem z kalibracją kompasu.

 

Znalazłem coś ciekawego, wygląda na to, że problem z GPS występuje w momencie jak jest fon podłączony przez kabel do usb (to by się zgadzało w moim przypadku).
Według tego opisu, brak aktywacji appki Starlink by Subaru, dezaktywuje software'owo przetwarzanie sygnału GPS w IOS, co objawia się 'gubieniem' sygnału GPS np. na mapie (w moim przypadku Google, yanosik również nie działał prawidłowo).

https://discussions.apple.com/thread/7141432

https://www.subaruoutback.org/forums/138-gen-5-2015-2019/407266-actual-fix-iphone-6s-gps-erratic-behavior.html

W weekend sprawdzę czy opisane metody pomagają. Wydaje mi się to mocno prawdopodobne, ponieważ problem nie występował z telefonem Żony, a ona ma OS androida.

Edited by franek-b
  • Thanks 1
Link to comment
Share on other sites

15 minut temu, franek-b napisał:

Znalazłem coś ciekawego, wygląda na to, że problem z GPS występuje w momencie jak jest fon podłączony przez kabel do usb (to by się zgadzało w moim przypadku).

 

Jak tak się zastanowię, to faktycznie chyba problem jest tylko na kablu.

Link to comment
Share on other sites

Pisałem już w innym wątku - problem występuję przy podłączeniu kablem USB ze stacją multimedialną. W przypadku zasilania z zapalniczki lub z gniazda USB tylko do ładowania jest OK tzn ten problem nie występuję ale ...... występują wszystkie pozostałe ;)

Link to comment
Share on other sites

2 godziny temu, franek-b napisał:

 

OK, to temat się wyjaśnił :)

 

 

To nie eye sight - tak jak koledzy pisali chodzi o podłączenie do stacji multimedialnej (ale czy temat się wyjaśnił?). Ja nie rozumiem dlaczego przez 3 miesiące Yanosik działał ,a teraz się gubi. Też miałem takie jak opisano objawy w Google Maps. Właśnie dyskutowalismy o tym tutaj:

... może lepiej tam kontynuować bo ten temat sugeruje, że winny jest eye sight. 

 

Edited by Urbi
Link to comment
Share on other sites

W dniu 13.11.2018 o 18:39, franek-b napisał:

To mały update tematu, po sprawdzeniu, ładowanie przez gniazdo zapalniczki rozwiązuje problem iphona i 'głupiejących' map googla.

Solved ;-)

 

... no rozwiązuje o tyle, że znowu jest jak w 20-letnim aucie. Nie możesz z tego telefonu np. posłuchać muzyki. Nie wiem jak u Was, ale u mnie jakość przez BT jest dużo gorsza. 

Edited by Urbi
Link to comment
Share on other sites

Problem jest prosty z natury.

Przyczyną jest wadliwie działająca przetwornica napięcia 12>5V w stacji multimedialnej.

 

Być może kiedyś była sprawna, teraz jest nie sprawna, stąd generuje zakłócenia RF/mag.

Przyczyną mogą być zepsute kondensatory... to się da naprawić. Kwestia podłączenia pod sprzęt i sprawdzenia co się tam dzieje.

Link to comment
Share on other sites

24 minuty temu, dubelt napisał:

Problem jest prosty z natury.

Przyczyną jest wadliwie działająca przetwornica napięcia 12>5V w stacji multimedialnej.

 

Być może kiedyś była sprawna, teraz jest nie sprawna, stąd generuje zakłócenia RF/mag.

Przyczyną mogą być zepsute kondensatory... to się da naprawić. Kwestia podłączenia pod sprzęt i sprawdzenia co się tam dzieje.

 

:)

Skąd ta pewność? 

Edited by Urbi
Link to comment
Share on other sites

Tak wynika z opisywanych syndromów.

Nie działa zasilane ze stacji multimedialnej " problem z GPS występuje w momencie jak jest fon podłączony przez kabel do usb ", nie ma problemu jak podłączone pod zapalniczkę.

 

Morał taki że przetwornica ze stacji multi robi sieczkę a ta z zapalniczkowej ładowarki nie robi.

 

Chyba że pytanie dotyczyło o zepsute kondensatory - najczęściej powodują rozjechanie się pracy przetwornicy, najsłabszy element na którym producenci czasem przy-oszczędzają.

Edited by dubelt
Link to comment
Share on other sites

9 godzin temu, Urbi napisał:

 

... no rozwiązuje o tyle, że znowu jest jak w 20-letnim aucie. Nie możesz z tego telefonu np. posłuchać muzyki. Nie wiem jak u Was, ale u mnie jakość przez BT jest dużo gorsza. 


No fakt, dla mnie jest to rozwiązanie wystarczające, ponieważ nie słucham muzyki z fona. Przyczyna jest czysto software'owa - o czym pisałem wcześniej i załączałem linki. Ponieważ nikt nie czyta załączników (dlatego nie chodzi o popsute kondensatory), wklejam rozwiązanie problemu pełniejsze - umożliwia współpracę iphona ze stacją.
 

2 godziny temu, dubelt napisał:

Tak wynika z opisywanych syndromów.

Nie działa zasilane ze stacji multimedialnej " problem z GPS występuje w momencie jak jest fon podłączony przez kabel do usb ", nie ma problemu jak podłączone pod zapalniczkę.

 

Morał taki że przetwornica ze stacji multi robi sieczkę a ta z zapalniczkowej ładowarki nie robi.

 

Chyba że pytanie dotyczyło o zepsute kondensatory - najczęściej powodują rozjechanie się pracy przetwornicy, najsłabszy element na którym producenci czasem przy-oszczędzają.

 

Nie ma problemu z ładowaniem. Jest jedynie problem z sygnałem GPS - takie objawia się na nawigacji. I co jeszcze ciekawsze to dotyczy to tylko iphonów :-) dziwnie popsuty kondensator, który nie działa tylko dla jednego OSa ;-)

 

Rozwiązenie problemu

 

Cytat

 

The problem is .... Starlink!

Starlink refers to several things, so I want to get the terminology straight. There is an iPhone app called SUBARU STARLINK (yes, all caps! Subaru should learn about the Caps Lock key next time they submit an app to the Apple Store). There is also the STARLINK app in the Apps section of the Subaru head unit.

When I first got the car I downloaded the iPhone SUBARU STARLINK app and saw immediately that it was pretty useless. I don't use it. However, I discovered that, if I want GPS to work on the iPhone, I must start STARLINK on the head unit.

Here's what works for me:

  1. Start the car.
  2. Press the Apps button on the head unit.
  3. Press the STARLINK button on the display after it is enabled.
  4. Plug in your iPhone. The head unit asks, "Are you sre you want to close STARLINK?"
  5. Press NO.

 

Nie testowałem tego, ale może spróbujesz, ja mogę najwcześniej w sobotę.

Edited by franek-b
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...